Moreterra crashes (doesnt even open)

Aug 25, 2011 at 3:46 PM

Hello all 

Moreterra crashes and it doesnt even open 

The problem is:

Problem signature: Problem Event Name: CLR20r3  Problem Signature 01: moreterra.exe  Problem Signature 02: 1.0.0.0  Problem Signature 03: 4e4ed288  Problem Signature 04: System.Xml  Problem Signature 05: 4.0.0.0  Problem Signature 06: 4ba1dfec  Problem Signature 07: 73b  Problem Signature 08: 0  Problem Signature 09: System.Xml.XmlException  OS Version: 6.1.7601.2.1.0.256.1  Locale ID: 1033  Additional Information 1: c162  Additional Information 2: c162640cb9b038afa6bb56e438577524  Additional Information 3: 5e6f  Additional Information 4: 5e6f896e52f296a778831fd079b240c9

 

I hope i telled everything

(windows 7 64 bit moreterra 1.6.1)

Aug 25, 2011 at 5:20 PM

Is this the first time you've tried to run moreterra? Were you using any previous version?

Developer
Aug 25, 2011 at 9:30 PM

Well, that's one of the stranger things I've seen for error reporting.  I wonder why Win7 reported things in such a obscure way.

 

Well, it's looking like it was the Sig 09 (System.Xml.XmlException) that is causing the issue here.  One of the very first things
that MoreTerra does when starting up is attempt to load from it's UserSettings.xml file.  It only saves to this file when the program
gets shut down at the very end.

So with the program crashing before the main window even shows up it has to be crashing when loading this file, which means it
has to already exist.  If it does not exist then the default settings are used instead.

So I can not say what is causing the Xml file to crash but I would suggest you attempt to remove the UserSettings.xml file and run
the software a few times to see if it saves and reloads properly.

To do this open up any folder on the machine and change the text in the address bar at the top to /%APPDATA%/MoreTerra/
You could also put this in the Run option on the Start Menu but it seems that is not available by default in Windows 7.
The folder that appears should have a folder called Resources and one called Logs along with the UserSettings.xml file.

Let us know if deleting this settings file clears up the issue.  Thanks

Aug 26, 2011 at 2:49 PM

Thanks Solsund it worked! 

Developer
Aug 27, 2011 at 12:24 AM

Glad to hear it.