Doesn't start (no error given)

Jul 19, 2011 at 3:48 PM

Hi,

I have Win XP and whenever I run this program it doesn't even start up... no idea what I am doing wrong/
Developer
Jul 19, 2011 at 8:59 PM
Edited Jul 19, 2011 at 9:00 PM

Three things,

Are you using the latest version of the software?  Anything older than 1.5 might have a bug that caused XP clients to crash on startup.

Are you running the program itself and not the other file that says also says "NoGui"?  If you run the NoGui one you might see a brief flicker of black before it shuts down.

Jul 20, 2011 at 2:25 PM

I am running 1.5, and yes running the program itself not the NoGUI file.  But I have tried the NoGUI file too and just get the commandprompt screen to flicker briefly.   Dont know what else to do.   I actually got a .net error one time only, but now back to just doing nothing again.

Developer
Jul 20, 2011 at 9:09 PM

The only other thing I can think of is to ask if you have .NET 4 installed, which if you can play Terraria on the machine is a yes anyways.

 

Otherwise there's not enough information to know where things are failing or even what is happening.  I could probably whip up a version

with a very basic log system in it to maybe get some more information about what is happening.  

Jul 20, 2011 at 11:12 PM

Yeah I already had .net4.0 installed but not 3.5 which I think was the problem because soon as I installed that the program started!

Thank you for the help mate.

Developer
Jul 21, 2011 at 9:03 PM

You know, I noticed something when working with the code about the target being set to 3.5 but I wasn't sure that was for .NET.  

It's sounding like that's what that was.    And sure enough there it is.  It's set to 3.5 for the target.  

Might have to change that to match Terraria just to keep it simpler for people.  Thanks for pointing this out.

Jul 22, 2011 at 12:33 AM

I've been having the same issue as everyone else with the first World Viewer 1.5 version, however the fix and MoreTerraria 1.5 still haven't worked for me, as I'm running Windows 7, which appears to only have .NET 4 installed. So far I haven't had any luck getting 3.5 installed.

I was able to get the fix  and new version to run on an XP VM, but its a pain to have to start that up every time I want to get my Terraria "map" up and running.